[PlanetCCRMA] xruns

foltra@terra.cl foltra@terra.cl
Thu Oct 2 11:19:01 2003

Hi, Jonathan

On Wed, 01 Oct 2003, Jonathan Segel wrote:

> >
> >1.4.  What's an xrun?
> >
> >It's a generic term used to describe a situation where the software
> >did not keep up with the hardware, either by feeding it data, or by
> >collecting data from it.
> thanks! couldn't find that for whatever reason. improper googling i guess.
> but after the rest of this discussion i guess that isn't the problem 
> either, as it only shows up on jack's boot. (...eew..)
> >If you're haven't read
> >http://www.linuxdj.com/audio/lad/resourceslatency.php3,
> >then your system is probably misconfigured.
> >
> at this point i don't think it's the system software parts. i'm just 
> trying to get a stereo sound out cleanly!
>  i have been reading alot - most of the time that i should be making 
> music - and this computer (actually not the one i am typing on now) 
> is a 2.4ghz P4 on a VIA mainboard with 768 MB ram, which seems fully 
> capable. i installed the redhat planet-ccrma w/ capabilities 
> ensconced, 2.4.20-20.1.caps.rh90. alsa has the proper drivers for the 
> VIA82xx built-in sound and midi, the .asoundrc file is to that 
> hardware, lsmod looks good, everything works, but the sound coming 
> out is messed up with (cyclic, i believe) digital clicks and pops. 
> almost tremelo! i've tried to configure all the things i can that i 
> have read, (kernel, alsa, hdparm) - what's left is irq? - but i can't 
> see how to change it. it seems to reside on IRQ 5 alongside the usb 
> ports. i cannot physically move the sound card, it's built in. it has 
> stereo mini-plugs i/o + line out plus spdif rca and optical. if i do 
> lspci -vvv, while every other bus shows a line that states its 
> latency (32 in most cases) the audio card does not have this line 
> (??).
This is for sure you're problem, shared irq between soundcard and usb,
You should be able to set the irq of the soundchip on the bios setup.
Also irq 5 is a low priority irq (so it's says on jan's excelent guide).
Else you can forget about the via chip, it's crappy anyway.

> actually i haven't tried the spdif outs yet .. hmmm..
> >You can test your setup with the latencytest tool, available at
> >http://www.linuxdj.com .
> couldn't make this. liblatencygraph.a  has an undefined reference to 
> gdImageGif   and it quits out its making.
Newer versions of libgd doesn't support gifs due to freedom restrictions :)
you can try searching for the old libgd, but i don't think it's 
worth the effort. Just fix  your setup.

I had irq problems after upgrading to kernel 2.4.22 (planetccrma),
with the nic usb and my DSP24 on irq 5, fixed it by setting the
pci irq to 9 for the dsp24, and boot with option acpi=off.
Now i'm happy. Sorry for the *personal experience plug* :) 

> whine whine whine, all i do is whine. thanks for help of any sort, 
> lest i appear ungrateful for all the work to get me as far as i am 
> now.
> -- 
> _________________________________________________________________
> Jonathan Segel  -- MAGNETIC -- PO Box 460816 S.F. CA. 94146-0816
>               4014 Brookdale Ave. Oakland, CA 94619
>   jsegel@magneticmotorworks.com <-----> magsatellite@yahoo.com
>                http://www.MagneticMotorworks.com
>    tel (510) 534 7825  cell (510) 484 7415  fax (425) 955 4495
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma