[PlanetCCRMA] CCRMA--RH9--ALSA--Hammerfall HDSP9632

Ludo Max ludo.max@uconn.edu
Sun Nov 23 14:24:00 2003

Hi all --

I am trying to set up RH 9 with CCRMA on a P4 2GHz with Hammerall HDSP9632. The
machine also has built in audio on the motherboard, but that is - for obvious
reasons - not needed (or wanted). We need the absolute lowest latency possible
for speech research purposes, so I am trying to this with ALSA drivers.

I installed CCRMA from the web. The kernel installed without problems and the
machine boots fine (offering both kernels in GRUB).

I did /usr/sbin/alsaconf. It detected both the built-in audio and the
Hammerfall. The test sound was not played so I assumed this was just because the
OSS drivers were already loaded (first boot after boot I let RH configure the
Hammerfall which it had detected; shouldn't have let RH do that but did anyway).

I have tried #-out from the /etc/modules.conf file the lines that specifically
refer to the OSS drivers, but that did not help. So far there is still no audio
on this machine and I do not know how to proceed....

The /etc/modules.conf file currently looks like this:

alias eth0 e100
alias usb-controller ehci-hcd
alias usb-controller1 usb-uhci
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 0.9.0 ---
alias char-major-116 snd
alias snd-card-0 snd-hdsp
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
#alias sound-service-0-0 snd-mixer-oss
#alias sound-service-0-1 snd-seq-oss
#alias sound-service-0-3 snd-pcm-oss
#alias sound-service-0-8 snd-seq-oss
#alias sound-service-0-12 snd-pcm-oss
options snd major=116 cards_limit=1
options snd-hdsp index=0
# --- END: Generated by ALSACONF, do not edit. ---

At various stages, I have also #-out the lines "alias char-major-116 snd" and
"alias sound-slot-0 snd-card-0" but with no success. Please let me know if
further modifications to this file are necessary.

When I type /etc/rc.d/init.d/alsasound start I get the following error message:
Starting sound driver snd-hdsp
/lib/modules/2.4.22-6.ll.rh90/kernel/sound/snd-hdsp.o: init_module: No such device
/lib/modules/2.4.22-6.ll.rh90/kernel/sound/snd-hdsp.o: insmod
/lib/modules/2.4.22-6.ll.rh90/kernel/sound/snd-hdsp.o failed
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22-6.ll.rh90/kernel/sound/snd-hdsp.o: insmod snd-hdsp failed

Can someone offer some suggestions please as to how to get this Hammerfall board
up and running?

Thank you in advance.

Ludo Max