[PlanetCCRMA] Sound driver suddenly not being found

Mark Knecht mknecht@controlnet.com
Fri Nov 21 13:46:01 2003

> Suddenly after a reboot I found that ALSA was not starting and the
> snd-ice1712 driver was not loading.  Attached is the part of boot log
> which shows that it's not being found.  I hadn't changed anything that
> I'm aware of in the configuration.
> Any idea what would cause this or what to do about it?
> Thanks.

This happens periodically with both my Hammerfall and my HDSP 9652. Usually
a cold boot, or even a warm boot, solves the problem for me.

Don't ask me what's going on. lspci shows the device is there, but at boot
time the Alsa didn't find it. The HDSP 9652, which I use under Linux more
often, is in a fast machine and it fails more often. I've had a suspicion
that there is a timeout going on with the card getting it's internal
firmware loaded (it's FPGA based) and that when the driver says it tried 100
times it really would find the card more often if it tried 200 times.

Just my 2 cents...

Good luck,