[PlanetCCRMA] guaranteed deadlock w/ 2.4.20-4.ll.acpi

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Wed May 14 12:52:01 2003

> I am running redhat 8.0 with kernel-2.4.20-4.ll.acpi, jack-0.7.x (tried
> 0.70.. and the freshly updated 0.71..) and ecasound. Filesystems are all
> ext3. Even when I run jack without the "-R" switch and as an unpriviliged
> user, using 2 simultaneous sessions of ecasound to record (ecasound -t:60
> -i:jack_alsa -G:jack,ecasound_rec1,streaming -o stdout) as root with or
> without the "-r" switch, my system will deadlock reliably and immeadiatly.

Is this only happening with ecasound? (and only with two copies running
at the same time?) Or do you see the problem with other jack software as

> It still responds to pings but nothing else. I am running with low-latency
> on. The system is remote, so it's sort of a pain to test out different
> configurations.

Yuck. It sounds like an infinite loop on a SCHED_FIFO process (ie:
anything interrupt related may work but no processes get to be
schedulled at all other than the realtime process sucking up all cpu
cycles). But you mention that it also happens when you run as a normal
users with no special privileges so that should not be the problem. 

Of course, as you say, it could also be alsa...
-- Fernando