[PlanetCCRMA] Trouble with rebuilt kernel from 2.4.19-1.ll source on RH8.0

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Mar 24 10:29:01 2003

> > Well, maybe 2.4.19 does not like gcc3.2, I have not tried that
> > combination. 
> For the record, I wasn't able to identify the cause(s) of the problem.  But
> I do now have a working 2.4.19 kernel.
> Some more clues did pop up tho:
> - When I tested further with the planet CCRMA kernel, I did experience a
> gnome-panel segfault...
> - I was able to build a 2.4.19-1.ll kernel on gcc3.2 which gnome-panel
> doesn't segfault.  Strangely, the configuration was the just the same as
> that I'd tried previously: and is the same used to build the binary planet
> kernel.
> What does this suggest?  I think that there may be factors at work beyond
> the kernel itself...

If you are not getting consistent results (ie: you use the same
configuration and the same build process but the results are different)
then a hardware fault may be responsible (disk or memory). I have seen
this happen but the end result is usually that gcc just segfaults at
random places and something like that would just kill the build process
completely (you would not get a binary rpm at all). 

-- Fernando