[PlanetCCRMA] Trouble with rebuilt kernel from 2.4.19-1.ll source on RH8.0

Daniel Heckenberg daniel@bogusfront.org
Thu Mar 20 20:13:01 2003

On 21/3/03 1:01 PM, "Fernando Pablo Lopez-Lezcano"
<nando@ccrma.Stanford.EDU> wrote:

>> I'm trying to rebuild my kernel from the source in the planet ccrma rpm
>> (2.4.19-1.ll) under RedHat 8.0 (and therefore gcc 3.2).  I've been using the
>> .config from the prebuilt kernel.
> Are you rebuilding the binary rpms or just using the source that is
> there to build your own? The configurations are stored in the configs
> directory...

I've installed the source from the ccrma rpm.  Then I've tried to build a
kernel using:
- the original .config in usr/src/linux-2.4.19-1.ll/
- /boot/config-2.4.19-1.ll/

and I've also tried using make oldconfig starting from the RH 8.0 config
file for 2.4.18-27

I get the same problems in every case.

>> The build goes fine, but I get segfaults from applications when I'm running
>> the new kernel.
>> In particular, gnome-panel segfaults when I start X.  Synaptic also
>> segfaults.
> Look at /var/log/messages and see if there are any indications of kernel
> problems. It sounds strange to me. But I have not rebuilt 2.4.19 under
> gcc3.2. I am using gcc3.2 to build newer kernels and I have not had
> problems so far. 

I have had a look in /var/log/messages and there didn't seem to be anything
obvious.  I'll have a close look when I'm back on that machine.  It does
seem kernel related as I can use the prebuilt RH or CCRMA kernels without

I can have a crack at using strace to narrow done onto the problem but as
I've not done this before I'm not sure how much use that is.

Are there any other ways to diagnose these problems?
>> I haven't had a chance to trace into this much, but I'd thought I'd ask if
>> this a known problem with an easy solution... or if it's my problem with no
>> solution (as yet...)
>> System is a Dell Inspiron 8100 laptop.
> Maybe you need to rebuild the X drivers? Is this an NVidia based laptop?
> If so you will need to get the (binary) drivers and rebuild them under
> the new kernel.

It is an nVidia based machine but I'm just using the VESA driver for X until
I've managed to get the kernel running properly...

Thanks for your assistance.