[PlanetCCRMA] apt-get dist-upgrade problem

Chris Albert christopher.albert@sympatico.ca
Thu Mar 13 15:19:01 2003

Mark Knecht wrote:

>>I'm still having the same problem Thomas is having. apt-get is trying to 
>>install a package that is already installed . In my case it is openssl . 
>>Is the best way to get the rpmdatabase back in sync to manually (ie. rpm 
>>-e ) the offending package and let apt-get re-install?
>Don't know if it's the best, but it has been recommended before....
>PlanetCCRMA mailing list
I recently had the same problem with the same version of openssl
installed and marked _as to-be-installed_ by "apt-get dist-upgrade".
Rebuilding the rpm database did not fix the problem.
I personally avoid solutions of the type "rpm -e --nodeps ..." which tends
to corrupt the rpm database. What I have found is that it is better to work
with the apt "envelope" to rpm.
A  brute-force approach as in "apt-get install openssl" in
the present circumstances makes clear the deep dependencies that
openssl has(which in linux is one of the most important crypto packages),
since about a hundred packages need to be _uninstalled_. However,
a "apt-get --reinstall install openssl" worked fine and eliminated the
'apt-get dist-upgrade' conflict.

I'm sorry to say that I dont understand apt well enough to explain this 
so I offer this solution with the miraculous caveat "it worked" -- since 
the irritating 'openssl double bind' messages was more important to me 
than a deeper
understanding of apt's database integrity management.