[PlanetCCRMA] problem installing cmucl-cm-clm-cmn

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Dec 23 10:02:01 2003

> > What happens if you do a:
> >   /usr/bin/lisp -core /usr/lib/cmucl/lisp-dist.core
> Still segfaults.  Since we eliminated the cmucl-cm-clm-cmn core, that made me 
> think the problem is in cmucl.

It is...

> So, suspecting cmucl, I apt-got source cmucl, planning to recompile it 
> myself...  then discovered "Note that to recompile CMUCL you need a working 
> CMUCL system :-("

I could have warned you :-) I tried that and spent a couple of days
trying to get it up and running (basing the compile on the hack I did
that managed to get it running in the first place). No way. I managed to
get it built but it would always segfault, no matter what I did. Finally
I decided to call it quits and use the hack - which apparently does not
work for everybody. 

> So (here's the payoff), I poked around a bit and discovered that you can 
> actually run ld-linux.so explicitly.  I changed /usr/bin/lisp to this...
> LD_ASSUME_KERNEL=2.2.5 LD_PRELOAD=/usr/lib/cmucl/lisp/libdl-2.3.2.so exec 
> /lib/ld-linux.so.2 /usr/bin/lisp.bin $@
> ...and now it works.  That still leaves several questions unresolved though:

Wow! Good detective work!

> 1) Why was it working for others, but not for me?

It is working here, I have no idea why it does not in your case. I'll
pole around a bit more. 

> 2) Why does explicitly calling ld-linux work for me, but not without?
> --wes (not fully indoctrinated into the mysteries of dynamic linking)

Don't look at me for advice :-)

At the time I looked at sbcl (a cmucl derivative) as an option. There
are rpms in the site and they built and did run fine. Regretfully at the
time clm did not have sbcl support. I think it does now, so I should
look at it again. I would really want to leave cmucl behind, the "can't
rebuild without a working cmucl" stumbling block is a major pain as was
proved by FC1. 

-- Fernando