[PlanetCCRMA] Re: [CM] no sound with latest kernels/alsa modules

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Thu Dec 11 15:33:01 2003

> Thanks for the reply; my responses with requested information are inline
> below.  Two other points in addition:
> 1. Even if I do something goofy like "cat /dev/random > /dev/dsp", I
> hear absolutely nothing.  This used to at least make a horrible noise.

That would use OSS emulation. I take it you have tried to play a wav
file using, for example, aplay (which uses the native ALSA interface). 

> 2. I notice that the "Master" control in alsamixer or gnome-alsamixer no
> longer has a "mute" option.  Is it possible that it's somehow muted and
> can't be unmuted?  The following doesn't work:
> # amixer set Master 100 unmute
> amixer: Unknown playback setup 'unmute'..

Looks like you have the proper packages (latest alsa and kernel). I
don't know where to go from here, looks like you have already tried
tweaking all the controls in alsamixer (or gamix if you want a GUI),
which is what I would suggest. 

This may be a bug in ALSA itself, maybe you should post to the
alsa-devel list to see if somebody else is hitting the same problem. 

> >> There is a very old alsa-kernel there for 2.4.21...
> I've tried installing that, but I get the following error, even if I
> have booted the 2.4.21 kernel:
> rpm -ivh alsa-kernel-2.4.21-1.ll.acpi-0.9.4-2.cvs.i386.rpm
> error: Failed dependencies:
>         kernel-version-arch = 2.4.21-1.ll.acpi-i386 is needed by
> alsa-kernel-2.4.21-1.ll.acpi-0.9.4-2.cvs

You need to get the package with the architecture that matches your
kernel (probably i686 - 'rpm -q --qf "%{ARCH}\n" kernel_package' should
print it if you are not sure). 

> I presume I should not just force it with --nodeps, right?

You can but it will not work, you need the modules that match your
-- Fernando