[PlanetCCRMA] Re: [CM] no sound with latest kernels/alsa modules

Noel Bush noel@x-31.com
Thu Dec 11 12:56:02 2003

Thanks for the reply; my responses with requested information are inline
below.  Two other points in addition:

1. Even if I do something goofy like "cat /dev/random > /dev/dsp", I
hear absolutely nothing.  This used to at least make a horrible noise.

2. I notice that the "Master" control in alsamixer or gnome-alsamixer no
longer has a "mute" option.  Is it possible that it's somehow muted and
can't be unmuted?  The following doesn't work:

# amixer set Master 100 unmute
amixer: Unknown playback setup 'unmute'..

On Thu, 2003-12-11 at 15:12, Fernando Pablo Lopez-Lezcano wrote: 
> [I'm cc'ing the Planet CCRMA list...]
> > Sorry to reply to myself, but I have tried removing *all* alsa packages
> > so I could reinstall the latest (dependencies of planetccrma-core).  Now
> > I don't have any sound, and I cannot reinstall the modules for the
> > previously working version!  So I'm totally stuck, with absolutely no
> > sound from any application, and no indication of errors anywhere I can
> > find.  Help!!!!!
> Sorry for the trouble. What is it you have installed now? What versions
> of ALSA? Do an "rpm -q -a | grep ^alsa" and post the result.

# rpm -qa | grep ^alsa

> Which kernel are you booting? (if it is the latest it should be
> 2.4.23-1.ll.xxx), see which one you are booting by typing "uname -r". 

# uname -r

> And finally, what hardware do you have? Do an "lspci -v -v", one of the
> entries should correspond to the sound card (or which module are you
> loading for your card?). 

I have an SB Audigy, and I'm using the emu10k1 module.  Here's the lspci

# lspci -v -v
01:0a.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
        Subsystem: Creative Labs SB0090 Audigy Player
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (500ns min, 5000ns max)
        Interrupt: pin A routed to IRQ 5
        Region 0: I/O ports at c400 [size=32]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

> Anyway - I have not erased all the old alsa modules from the web site
> yet. Maybe you will find what you need at:
> http://www-ccrma.stanford.edu/planetccrma/mirror/redhat/linux/planetcore/9/en/os/
> There is a very old alsa-kernel there for 2.4.21...

I've tried installing that, but I get the following error, even if I
have booted the 2.4.21 kernel:

rpm -ivh alsa-kernel-2.4.21-1.ll.acpi-0.9.4-2.cvs.i386.rpm
error: Failed dependencies:
        kernel-version-arch = 2.4.21-1.ll.acpi-i386 is needed by

I presume I should not just force it with --nodeps, right?

> -- Fernando
> > > I've used apt-get update/upgrade to get the latest planetccrma-core, but
> > > I have found that whenever I boot with any of the following kernels, I
> > > cannot get any sound:
> > > 
> > > 2.4.23-1.ll.rhfc1.ccrma
> > > 2.4.22-1.2129.nptl.caps.rhfc1.ccrma
> > > 2.4.22-9.23rc3.ll.rhfc1.ccrma
> > > 2.4.22-1.2115.nptl.caps.rhfc1.ccrma
> > > 2.4.22-1.2115.nptl
> > > 
> > > The most recent kernel that does work for me is:
> > > 
> > > 2.4.21-1.ll.acpi
> > > 
> > > There are no errors when starting or restarting alsasound (except
> > > complaints about the change in names of controls by alsactl).  I've
> > > twiddled with the mixer to make sure nothing is muted.  I've checked to
> > > see that all modules are loaded with lsmod.  What else can I try?
> > > 
> > > Thanks in advance,
> > > Noel