[PlanetCCRMA] Incompatable dependecies after update of RedHat 8

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Dec 9 14:57:00 2003

> Thanks for your response.  I reloaded sources.list again but didn't see 
> any changes from what I was using.  I thought some of the gobbledegook 
> listed below could shed some light on the problem.
> --sources.list--

That seems to be fine... so let's try to find out what's going on. By
the way, I forgot to ask but could you do an "apt-get check" to see what
is the state of your dependencies before you try to install the Planet
CCRMA kernel and drivers?

> [root@robo1 apt]# apt-get -o RPM::Install-Options::=--oldpackage
> install 
> planetccrma-core
> Reading Package Lists... Done
> Building Dependency Tree... Done
> You might want to run `apt-get -f install' to correct these:
> The following packages have unmet dependencies:
>  cups-devel: Depends: cups-libs (= 1.1.17) but 1:1.1.15-10 is to be 
> installed

This is what I have in my 8.0 box:
# rpm -q cups cups-devel
What do you see in your machine? It looks like you have an older version
( but with an epoch of "1" (which preempts 1.1.17-0.9).
Where did you get that from? I think the version I have is the latest
RedHat update. Do an rpm -q -i cups to get more information about the

>  kdelibs-devel: Depends: kdelibs (= 6:3.0.5a-5) but 6:3.0.3-8 is to be
> installed

This one is weird. Could you see what version of kdelibs you have
installed? (rpm -q kdelibs)

>  planetccrma-core: Depends: kernel-version-arch (=
>                    Depends: alsa-kernel-arch-2.4.22-6.ll.rh80 (= 
> 0.9.6-2.cvs.rh80-athlon)
>                    Depends: midishare-kernel-arch-2.4.22-6.ll.rh80 (= 
> 1.86-2.rh80-athlon)
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or 
> specify a solution).

-- Fernando