[PlanetCCRMA] Incompatable dependecies after update of RedHat 8

John Dey jsdey@optonline.net
Tue Dec 9 12:03:01 2003

Hello Everyone:

I am joining this list to see if there is someone that could provide 
some guidance on my installation difficulties.

I am trying to install rosegarden4 on my RH8 host computer connected to 
the Internet through a server on my private network.  I am now using 
apt-get but getting the following dependency mismatchs.  (I have down 
loaded CD images and downloaded directly from the Internet with the same 
results.) I have done the apt-get update and then apt-get dist-upgrade 
(note that the dist-upgrade produces a very similar response to the on 
listed below) and got the following response:

[root@robo1 apt]# apt-get -o RPM::Install-Options::=--oldpackage install 
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
 cups-devel: Depends: cups-libs (= 1.1.17) but 1:1.1.15-10 is to be 
 kdelibs-devel: Depends: kdelibs (= 6:3.0.5a-5) but 6:3.0.3-8 is to be 
 planetccrma-core: Depends: kernel-version-arch (= 2.4.22-6.ll.rh80-athlon)
                   Depends: alsa-kernel-arch-2.4.22-6.ll.rh80 (= 
                   Depends: midishare-kernel-arch-2.4.22-6.ll.rh80 (= 
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or 
specify a solution).

I ran the command "apt-get -f install" but that did not fix the 
problem.  I downloaded the proper version of cups-libs and tried to rpm 
-U but the update was not allowed.  Any guidance would be greatly 
appreciated.  Thanks.