[PlanetCCRMA] Still stuck with Hammerfall HDSP.....

Mark Knecht mknecht@controlnet.com
Thu Dec 4 11:39:01 2003

> > I typed
> >
> > /etc/rc.d/init.d/alsasound start
> >
> > and got a message that the alsa drivers were already running
> BUT also an error......
> >
> > ALSA driver already running
> What happens if you do a "/etc/rc.d/init.d/alsasound stop" and then
> restart the driver? Does the driver get unloaded when you stop?

I have similar problems when doing updates to the Alsa drivers, and
sometimes just during cold boots. for my HDSP 9652. For me there has been no
solution to the problem along the lines of starting and stopping the
drivers. I've asked twice on Alsa-Devel how to do this but have never
received any answer to my question, much less a solution. I've tried doing
stops, then rmmod'ing anything that's still loaded, and then starting again.
All the drivers appear loaded, but I don't get sound in that case.

This is true up through 0.9.8. I have not tried it with 1.0.0rc1.

The good news is that except for sacrificing uptime, a reboot has always
gotten the drivers loaded on my system. I can't promise the same results on
the HDSP 9632, but it works for me here.

Good luck,