[PlanetCCRMA] recompiling kernel after adding a patch: newbie

Duke Jonathan Jason sysnon@tin.it
Tue Aug 26 06:50:03 2003

> > I saw this output searching on the archives of PlanetCCRMA, with 2
> > people or more having this result who posted questions, every email
> > had no answer,
> It's been answered several times... :-)

I searched all the archives, but I don't assure to have checked so deep :)
so far I found a longer explanation by u, but u couldn't give details on how
to modify spec file in that post

> > but the one with an explanation near to this link
> > http://ccrma-www.stanford.edu/planetccrma/software/recompilekernel.html
> >
> > so I probably instead going to /usr/src/redhat, but I don't know how
> > to modify spec file to add my patch,
> > I tried to do
> >
> > cd /usr/src/redhat/SPECS
> > rpmbuild -ba kernel-2.4.21-1.ll.acpi.spec
> After installing the source rpm for the kernel? You have to install the
> source rpm for the kernel and then try to rebuild the kernel from the
> spec file.

I have installed the rpm kernel source
from this link, that put files in /usr/src/redhat

moreover also the binary source (from core cd), that put files in
where I tried to make the first attempts of recompiling...before discovering
that I had to do in a different way

 If you get errors please let me know, the source rpm rebuilds
> without errors in my case...

I will post u the output of any encountered problem during the rebuilding,

hmmm, make sure you have disabled
> termination of the build in /usr/lib/rpm/redhat/macros, in particular
> the value in these two lines should be "0" instead of "1":
> %_missing_doc_files_terminate_build    0
> %_unpackaged_files_terminate_build    0

I will look surely at the suggestion u made

> > but I get errors
> >
> > so my answer is how to get out of this situation without quitting :)
> > who can help me how to recompile the kernel with the patch added in
> > the correct way?
> The proper way is to modify the spec file and rebuild, it is not easy, I
> know.
> > my system is redhat 9 with the planetCCRMA kernel 2.4.21-1.ll.acpi
> Do you know if those patches made it into 2.4.22?

I don't know, since I didn't still searched, anyway the modem is a Bewan usb
adsl st compatible,
and specifically for mdk9.1 or linux kernels 2.4.21-x needs those patches
added, since without, after doing a modprobe unicorn_usb, the modem turns
on, but I get (as specified from the modem drivers documentation) a system
freeze, and at the reboot a kernel panic after the usb checkin, telling me
problems with interrupts and somthin else I can't remember...after
unplugging the usb cable, all works fine...
but I'm trying to make work all :)

so from my not so documentated point of view these two patches r not kernel
specific, but modem specific, who work on kernel for being implemented.....

but probably u mean that I have to install kernel 2.4-22......so another
question rise...

do I have to uninstall the kernel rpm of 2.4.-21-1.ll.acpi? (doing rpm -e

> -- Fernando