[PlanetCCRMA] alsa init scripts

Kevin Bowen kevin@ucsd.edu
Fri Aug 22 10:24:01 2003

My symptoms were the same as yours, and Fernando's advice fixed it. I had an
alsasound script in my init.d directory which wasn't linked in any of the
rcX.d directories (and therefore wasn't getting called). chkconfig --add
fixed it.

-----Original Message-----
From: Alex Timmer [mailto:mijn_troep@yahoo.com]
Sent: Friday, August 22, 2003 3:56 AM
To: Fernando Pablo Lopez-Lezcano; Kevin Bowen
Cc: planetccrma@ccrma.Stanford.EDU
Subject: Re: [PlanetCCRMA] alsa init scripts

 --- Fernando Pablo Lopez-Lezcano <nando@ccrma.Stanford.EDU> wrote:
> If that is fine (which means alsasound will be started
> automatically on boot) then make sure you have saved the mixer
> configuration you want to keep, the following command will do
> that for you:
>   /usr/sbin/alsactl store
> (the mixer state will be saved in /etc/asound.state)
> Currently the script does not save settings when the machine is
> turned off, it just restores the settings that you have manually
> stored.
> -- Fernando

funny. my RH80 based machine does NOT restore the saved mixer
settings at the moment. (i use the latest cdrom images; with the
previous cdrom images i am sure it worked!)

after startup/login, all sound channels are muted. after executing
'alsactl restore' as root i get immediately my previously saved
settings (because i did follow the instructions with the 'alsactl
save' step, heh  =)

any clues as to where to look to fix it?

thanks, ALEX

Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/