[PlanetCCRMA] apt-get and alsaconf

Joseph Zitt jzitt@josephzitt.com
Tue Aug 12 19:39:01 2003

Digging further, this appears to be a bug in the Ximian Desktop. There
is a fix suggested in http://bugzilla.ximian.com/show_bug.cgi?id=44442

>From what I can tell, it has to be applied in building RPMs, but I'm not
clear on this. Is this something we can do ourselves, or does it have to
happen when you build the RPMs (which would be a pain for you, I know)?

On Tue, 2003-08-12 at 18:02, Fernando Pablo Lopez-Lezcano wrote:
> > Hi, all. I'm back again, trying out Planet CCRMA under Red Hat 9 on a
> > desktop system. 
> Hi and welcome back...
> > I'm getting the following when trying to install lilypond:
> > 
> > [root@aleph jzitt]# apt-get install lilypond
> > Reading Package Lists... Done
> > Building Dependency Tree... Done
> > You might want to run `apt-get -f install' to correct these:
> > The following packages have unmet dependencies:
> >   db4: Obsoletes: db1 but 1.85-0.ximian.6.1 is to be installed
> >   lilypond: Depends: guile (>= 1.6.4-7) but 5:1.6.0-4 is to be installed
> Are you sure /etc/apt/sources.list has the planet ccrma urls? The guile
> 1.6.4 package is there as far as I can tell (and it installs correctly
> in a machine I'm testing this on)
> Could you start by doing a:
>   apt-get update
>   apt-get check
> to see what is the state of your package dependencies before you start?
> >             Depends: libguile-ltdl.so.1
> >             Depends: tetex but it is not going to be installed
> >             Depends: tetex-dvips but it is not going to be installed
> >             Depends: tetex-latex but it is not going to be installed
> Strange, tetex is also there. 
> > E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
> > specify a solution).
> > [root@aleph jzitt]#
> > 
> > FWIW, this happened after I had installed the Ximian Desktop 2.
> Obviously it installs its own packages and those are conflicting with
> the Planet CCRMA dependencies. And/or the Ximian packages do not have
> proper dependencies. I have never tried Ximian so I don't know what
> might be the problem. 
> > I tried  'apt-get -f install' but didn't follow through since it wanted
> > to remove a huge number of packages from my system.
> Yes, that would not be good. We have to trace which package is
> triggering the dependency problems.