[PlanetCCRMA] apt-get and alsaconf

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Aug 12 18:03:00 2003

> Hi, all. I'm back again, trying out Planet CCRMA under Red Hat 9 on a
> desktop system. 

Hi and welcome back...

> I'm getting the following when trying to install lilypond:
> [root@aleph jzitt]# apt-get install lilypond
> Reading Package Lists... Done
> Building Dependency Tree... Done
> You might want to run `apt-get -f install' to correct these:
> The following packages have unmet dependencies:
>   db4: Obsoletes: db1 but 1.85-0.ximian.6.1 is to be installed
>   lilypond: Depends: guile (>= 1.6.4-7) but 5:1.6.0-4 is to be installed

Are you sure /etc/apt/sources.list has the planet ccrma urls? The guile
1.6.4 package is there as far as I can tell (and it installs correctly
in a machine I'm testing this on)

Could you start by doing a:
  apt-get update
  apt-get check
to see what is the state of your package dependencies before you start?

>             Depends: libguile-ltdl.so.1
>             Depends: tetex but it is not going to be installed
>             Depends: tetex-dvips but it is not going to be installed
>             Depends: tetex-latex but it is not going to be installed

Strange, tetex is also there. 

> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
> specify a solution).
> [root@aleph jzitt]#
> FWIW, this happened after I had installed the Ximian Desktop 2.

Obviously it installs its own packages and those are conflicting with
the Planet CCRMA dependencies. And/or the Ximian packages do not have
proper dependencies. I have never tried Ximian so I don't know what
might be the problem. 

> I tried  'apt-get -f install' but didn't follow through since it wanted
> to remove a huge number of packages from my system.

Yes, that would not be good. We have to trace which package is
triggering the dependency problems. 

-- Fernando