[PlanetCCRMA] Re: DVD playback not fluent

John Wheeler jdw27_42@hotmail.com
Tue Apr 15 10:38:02 2003

>Date: Fri, 11 Apr 2003 14:03:54 +0100 (BST)
>From: =?iso-8859-1?q?Alex=20Timmer?= <mijn_troep@yahoo.com>
>Subject: Re: DVD playback not fluent
>To: planetccrma@ccrma.Stanford.EDU
>hi John,
>is your /dev/dvd a real device or just a symbolic link? if the latter
>is the case, did you try hdparm as root on the 'real' dvdrom device?
>in my case /dev/dvd is a symlink to /dev/hdc and i have to use hdparm
>on /dev/hdc to get any effect.
>does your drive support dma? if you do 'hdparm /pathto/drivename' you
>get a listing of capabilities of the drive.
>hope this helps, ALEX

Yes, /dev/dvd is a symbolic link:

# ls -l /dev/dvd
lrwxrwxrwx    1 root     root           10 Nov 30 09:31 /dev/dvd -> 

AND /dev/cdrom is a symbolic link:

# ls -l /dev/cdrom
lrwxrwxrwx    1 root     root            8 Nov 27 17:26 /dev/cdrom -> 

but /dev/hdd is a real device:

# ls -l /dev/hdd
brw-------    1 john     disk      22,  64 Aug 30  2002 /dev/hdd

but, I still get the same error:

# /sbin/hdparm -d 1 /dev/hdd

setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma    =  0 (off)

and I get the following results:

# /sbin/hdparm -Tt /dev/hdd

Timing buffer-cache reads:   128 MB in  1.67 seconds = 76.65 MB/sec
Timing buffered disk reads:  64 MB in  6.22 seconds = 10.29 MB/sec

# /sbin/hdparm /dev/hdd

HDIO_GET_MULTCOUNT failed: Invalid argument
IO_support   =  3 (32-bit w/sync)
unmaskirq    =  0 (off)
using_dma    =  0 (off)
keepsettings =  0 (off)
readonly     =  1 (on)
readahead    =  8 (on)
HDIO_GETGEO failed: Invalid argument

# /sbin/hdparm -I /dev/hdd


ATAPI CD-ROM, with removable media
        Model Number:       DVD-ROM BDV212B
        Serial Number:      MT1318  Firmware
        Firmware Revision:  VER 0.37
        Used: ATAPI for CD-ROMs, SFF-8020i, r2.5
        Supported: CD-ROM ATAPI-2
        DRQ response: 50us.
        Packet size: 12 bytes
        LBA, IORDY(cannot be disabled)
        DMA: mdma0 mdma1 mdma2 udma0 udma1 *udma2
             Cycle time: min=120ns recommended=150ns
        PIO: pio0 pio1 pio2 pio3 pio4
             Cycle time: no flow control=227ns  IORDY flow control=120ns

So, it looks like the drive does have DMA capability.  Any idea what's going 
on?  (Also, what is a good hdparm -Tt value for smooth DVD playback?)

Thanks for your help -- I'm hoping this is valuable for others, as well.

MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*.