[PlanetCCRMA] Kernel 2.4.20-4.ll.acpi(smp) panic!

rncbc .net rncbc@hotmail.com
Fri Apr 4 02:49:02 2003

Hello nando et al.

>Thanks for the very detailed message. I'm glad you have the kernel
>working. Anyway, we could try to hand-copy the kernel oops and
>decode it but I think it is easier to wait a little bit for the
>next release (I hope to update the kernel more often in the future).
>I really don't have the resources (time) to try to find out what
>is really happening.
>-- Fernando

Yes, I can live with that :)

To get around my problem, I'm taking some trial-and-error approach (also 
coined brute-force-method elsewhere? :)

That is, I'm trying to rebuild a patched stock kernel (from kernel.org, not 
from RedHat!) and starting with the planetccrma's 
kernel-2.4.20-i686-smp.config as a base line.

So far, the build based on the unmodified kernel-2.4.20-i686-smp.config ends 
up in kernel panic on boot time (sched.c:577!). This is the very same 
behaviour of the planetccrma's kernel-2.4.20-4.ll.acpismp in question as of 
this thread.

Then, I've tried a new build based on a entirely personal configuration, 
which was in use effectively on a SuSE box that I maintain as a dirty lab 
(planetccrma's RH8 is supposed to be the clean one :). It worked out fine as 
posted here previously.

Later, I've managed to start a new build, again from planetccrma's 
kernel-2.4.20-i686-smp.config, this time changing it a bit, disabling some 
features I don't surely need and making others built-in as I know it will be 
always needed. Here goes a summary of the changes:

- Processor type: Pentium-III/Celeron (Copermine)
- High Memory support: No
- MTRR support: No
- EISA support: No
- PCMCIA support: No
- PCI Hotplug support: No
- BSD Process Acct.support: No
- Power Management support/ACPI support: No
- File systems/Ext3,FAT,MSDOS,VFAT: Yes (built-in)
- Advanced Partition support: No

Guess what? It works! No kernel oops here, and for now I'll keep this build 
as the production one. I've named this build as kernel-2.4.20-4.llsmp, as it 
is the most approximate to ones in planetccrma-core-smp to date.

After this relative success, the alsa drivers were also built from stock 
source (alsa-driver-0.9.2.tar.gz) and even lm_sensors-2.7.0 were carried out 
successfully (which failed miserably with planetccrma's original kernel 
source trees, dunno why but that wasn't much critical :). I use lm_sensors 
to keep track of inner system health (CPUs temperature and fan speed, system 
voltages, etc.)

Nevertheless, I'll keep trying until I isolate the culprit. I strongly 
suspect that it lies somewhere in the File systems and/or Advanced 
Partitioning support configuration, as the kernel boot hangs just when local 
file systems are being mounted. What you think?

As suggested, I will also try to hand-copy the kernel panic messages and 
post them here ASAP.

I'll give you notice as soon as I make progess. Till then...

I wish you all well and thanks,

rncbc aka Rui Nuno Capela

Add photos to your messages with MSN 8. Get 2 months FREE*.