[PlanetCCRMA] Audio kernel install problem (continued)

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat Sep 14 16:03:01 2002

>   I figured it out.  I tried the ext2 install and
> turned off Plug and play with no success.
>   So, I tried moving my hard drive from the Promise
> controller to the onboard ATA/66 and turned off the
>   The update worked fine.

Sorry, just back, I missed all the fun :-)

There were a bunch of questions and some speculation as to what might 
have been the problem... I'll try to answer some of them (might be useful 
for others stumbling into similar problems).

First, Jeffrey was having success booting from the RedHat kernel, but the 
Planet CCRMA kernel was failing, the fact that he _was_ booting into 
RedHat rules out things like:

 - BIOS 1024 boot limit (not usually a problem in modern machines)
 - settings in the BIOS
 - errors in the partition table

All of these would have affected both boot processes (I think). 

Perhaps the only question was whether the Planet CCRMA kernel had ext3 in
it ann the answer is yes, that's what I use in all machines. I try to 
mirror the RedHat configuration of the kernel when possible. 

BTW, I had never heard of any problems with regards to installing RedHat
that were due to ext3 - I don't see how that could happen, ext3 is just
ext2 with an additional journalling layer, whatever can read and write
ext2 will be able to read and write ext3.

So that pretty much leaves driver problems as the probable cause (and
that's why I was asking for error messages). And it turned out to be the
Promise raid controller. I have seen some very recent patches added to the
latest kernel that are still addressing problems with it, most probably
the RedHat kernel already incorporated them (or something similar) and
that's why it was able to boot. I'm surprised there were no errors
_before_ the failed mount, I was expecting to see something at a lower
lever (that would have pointed to the failing driver).

Good to know it works...
-- Fernando