[PlanetCCRMA] apt-get conflict resolution suspect?

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sun Dec 22 17:21:02 2002

> [root@Merlin root]# apt-get install synaptic
> Reading Package Lists... Done
> Collecting File Provides... Done
> Building Dependency Tree... Done
> You might want to run `apt-get -f install' to correct these:
> Sorry, but the following packages have unmet dependencies:
>   cdrtools-cdda2wav: Obsoletes: cdda2wav
>   cdrtools-cdrecord: Obsoletes: cdrecord

Are you pointing to other repositories in addition to planet ccrma?
"cdrtools-cdda2wav" is not part of the normal redhat install, it could
come from a rebuilt of the latest xcdroast and accompaining cdrtools
packages, without editing the spec file to match the package names to
the redhat names. 

>   kernel#2.4.18-14@i686: Conflicts: ppp (<= 2.3.15)
>   kernel#2.4.18-17.8.0@i686: Conflicts: ppp (<= 2.3.15)
>   kernel#2.4.18-18.8.0@i686: Conflicts: ppp (<= 2.3.15)
>   kernel#2.4.18-19.8.0@i686: Conflicts: ppp (<= 2.3.15)

This is strange...

> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or 
> specify a solution).
> [root@Merlin root]# man apt-get

Uh? You did not get a man page for apt-get? If so then you have a
problem with the installed apt packages. 

> [root@Merlin root]#
> [root@Merlin root]# rpm -q cdda2wav
> cdda2wav-1.10-14
> [root@Merlin root]# rpm -q cdrtools-cdda2wav
> cdrtools-cdda2wav-1.11a33-1

Wow, you have both of them installed? It should be one or the other, not
both. When you installed the second (cdrtools-cddawav) you should have
gotten a message from rpm regarding conflicts. Did you by any chance use
"--force" or "--nodpes" to install them?

> [root@Merlin root]# rpm -q ppp
> package ppp is not installed

Hmmm, strange, apt-get should not complain if ppp is not installed. I
don't think ppp is required for installing the kernel. But I just tried
erasing it here (with "--test") and you have to also erase rp-pppoe,
wvdial and redhat-config-network! Do you have those packages as well?
You probably have a broken dependency tree due to previous installs (or
uninstalls) of packages. 

> [root@Merlin root]# apt-get -f install
> Reading Package Lists... Done
> Collecting File Provides... Done
> Building Dependency Tree... Done
> Correcting dependencies... Done
> The following packages will be REMOVED:
>   Guppi-devel XFree86 XFree86-tools XFree86-twm XFree86-xdm Xtest cdda2wav
>   cdrecord eog evolution gdm gedit gnome-print gnome-print-devel gtkhtml
>   gtkhtml-devel iptables kernel#2.4.18-14@i686 kernel#2.4.18-17.8.0@i686
>   kernel#2.4.18-18.8.0@i686 kernel#2.4.18-19.8.0@i686
>   kernel-pcmcia-cs#1:3.1.31-9@i386 lesstif lesstif-devel libgnomeprint
>   libgnomeprintui lokkit mrproject nautilus nfs-utils openoffice pciutils
>   quota redhat-config-nfs rp-pppoe tcpdump vnc-server xawtv xinitrc
> 0 packages upgraded, 0 newly installed, 39 removed and 1 not upgraded.
> Need to get 0B of archives. After unpacking 306MB will be freed.
> Do you want to continue? [Y/n] n
> Abort.

You definitely do NOT want to continue, till you resolve the underlying
dependency problems :-)

Sometimes apt is not very smart in what it suggests. 
What does "apt-get check" tell you?
-- Fernando