[PlanetCCRMA] No /etc/asound.state

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat Dec 21 20:47:01 2002

> I am having trouble installing the ALSA drivers, and am informed "No
> mixer config in /etc/asound.state, you have to unmute your card!" after
> running alsaconf. I tried creating the modules.conf file manually using
> the template you provide, and it does the same thing.
> It all seemed to boil down to the fact that I do not have an
> "/etc/asound.state" file on my machine. I had a look on the web for one
> and couldn't find one, but everyone says to use 'alsaconf store' to
> create one automatically. Unfortunately this does not work for me.
> This is what it looks like from my console:
> [root@gateway root]# /etc/rc.d/init.d/alsasound start
> Starting sound driver snd-ice1712                          [  OK  ]
> Starting sequencer driver snd-seq-midi                     [  OK  ]
> No mixer config in /etc/asound.state, you have to unmute your card!
> [root@gateway root]# alsamixer
> alsamixer: function snd_ctl_open failed for default: No such file or
> directory

This is wrong, something seems to be missing in your installation. What
soundcard do you have? (Midiman?). What do you see if you do a "cat
/proc/asound/cards" and "cat /proc/asound/devices" from a terminal
window? Do you have a /dev/snd link? (it should have been created when
you installed the alsa drivers). 

Just to make sure you have everything installed could you do a:
  rpm -q -a | grep ^alsa
and post or email me the results?

It would seem like you don't have the proper device files. Hmmm, maybe
you tried to manually install things before? It could be library or
other files that are lefovers from a previous install. 

-- Fernando