[PlanetCCRMA] updated: alsa drivers.... finally!

Joseph Zitt jzitt@josephzitt.com
Tue Dec 17 20:15:02 2002

On 16 Dec 2002 14:43:45 -0800
Fernando Pablo Lopez-Lezcano <nando@ccrma.Stanford.EDU> wrote:

> Finally, I have just updated the ALSA drivers to today's CVS.
> Hopefully more frequent updates will follow (sorry for the delay on
> this one). Detailed instructions on how to upgrade can be found in the
> Planet CCRMA web page Changelog. Currently packages are available for
> the 2.4.19-1.ll up and smp kernels, 2.4.19-2.ll.acpi will follow
> shortly. 

OK, I'm in the process of installing them now. The changelog
instructions are quite clear (although I spotted one typo, in a line
that I had cut-and-pasted, where "alsasound" is written "alsasoud").

One thing I should fix on my system is that I had at one point enabled
the internal soundcard, a cs4236 compatible built-in thing, though that
has never worked for me usefully either. I suspect that I should remove
it, probably by editing /etc/modules.conf, but I'm not exactly clear on
what I should and shouldn't remove.

Here's the output that I got when I tried to restart ALSA:

[root@gimel midisport-firmware]# /etc/rc.d/init.d/alsasound start
Starting sound driver snd-usb-audio                        [  OK  ]
Starting sound driver snd-cs4236
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
init_module: No such device
insmod snd-cs4236 failed
Starting sequencer driver snd-seq-midi                     [  OK  ]
Restoring sound driver settings /usr/sbin/alsactl: set_control:782:
failed to obtain info for control #1 (No such file or directory)

... and here's my /etc/modules.conf:

[root@gimel midisport-firmware]# cat /etc/modules.conf
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci

# --- ALSA configuration
alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-usb-audio
alias snd-card-1 snd-cs4236
# --- OSS compatibility
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss
# --- Options
options snd device_gid=1 device_mode=0666 device_uid=0 cards_limit=2
major=116 card_limit=4
alias sound-slot-15 audio
options snd-usb-audio index=0 id=USB 
# options snd-cs4236 index=1 id=cs4236
# Trying options from
# http://duvet.eee.nottingham.ac.uk/laptop/linux_on_latitude.html
# options snd-card-cs4236 index=1 id=CARD_1 port=0x530  # cport=0x210
# mpu_port=0x330 fm_port=0x388 \
pre-remove sound-slot-15 /bin/aumix-minimal -f /etc/.aumixrc -S \
>/dev/null 2>&1 || :
# snd_irq=5 snd_mpu_irq=9 snd_dma1=1  # snd_dma2=-1 snd_isapnp=0
options snd-card-cs4236 port=0x530 cport=0x120 irq=5 dma2=1 dma1=0 \
id=CARD_1 index=1 
# --- Keep modules from being autocleaned
add options -k snd-card-0
# add options -k snd-card-1 io=0x530 irq=5 dma=1 dma2=0
add options -k snd-card-1
# --- ALSA configuration END
[root@gimel midisport-firmware]# 

As always, thanks for your continuing good efforts!

| jzitt@josephzitt.com                      http://www.josephzitt.com/ |
| GPG: A4224EFA                         http://www.mp3.com/josephzitt/ |
| == New book: Surprise Me with Beauty: the Music of Human Systems  == |
| Comma / Gray Code / VoiceWAVE Silence: the John Cage Discussion List |