[PlanetCCRMA] HDSP 9652 patch - Failed Dependencies

Mark Knecht mknecht@controlnet.com
Mon Dec 9 14:08:01 2002

   Maybe some of this is caused by me not actually being able to follow the
Planet installation instructions completely for this card? The instructions
basically take you through the process of install alsa, and then testing it.
One aspect of testing it is that you are supposed to be able to run
alsamixer, or some other mixer. However, on the Hammerfall series of cards I
cannot do this since I think it has no mix hardware in the design, or
possibly it does but isn't accessed correctly by the mixer application.

   Can I ask you to revisit the logic of the Planet installation process
with this in mind? On my previous machine that had a Hammerfall, the only
way I got it to work was to install two audio cards, the second of which had
MIDI and a hardware mixer.

   Also, I am reading between the lines that you believe I will have no
problems is the chkconfig --list alsasound said "1:on". Is this true? Or are
you just saying that this would have gotten the error message into the log
faster, but would not solve my real problem?


-----Original Message-----
From: planetccrma-admin@ccrma.Stanford.EDU
[mailto:planetccrma-admin@ccrma.Stanford.EDU]On Behalf Of Fernando Pablo
Sent: Monday, December 09, 2002 1:17 PM
To: Mark Knecht
Cc: PlanetCCRMA
Subject: Re: [PlanetCCRMA] HDSP 9652 patch - Failed Dependencies

> > You must have alsa enabled to start only on level 5 (X) and not on level
> > 3 (multiuser startup). See what "chkconfig --list alsasound" tells you.
> >
> OK, nothing obvious to me as of yet. I first tried chkconfig --list
> alsasound, but was told to run chkconfig --add alsasound first. I did
> that and now chkconfig --list alsasound says:
> [root@Godzilla root]# chkconfig --list alsasound
> alsasound       0:off   1:off   2:on    3:on    4:on    5:on    6:off
> [root@Godzilla root]#

What happened is that you did not enable the automatic startup of alsa
on boot (follow the planet instructions :-) So the driver was not being
started at boot (as it should) and instead the modules were loaded when
you started X (most probably because some program in the X startup
sequence needs the audio device).

> > Yuck... anything in the logs? (/var/log/messages).
> Here's what I could think to look at.
> QUESTION: I run RH 7.3. Why does dmesg say gcc is RH 7.2? Maybe this is
> normal? Or not?

It says that the kernel was compiled with gcc under rh 7.2, that is
normal as that's where I compiled the kernel.

> Hammerfall memory allocator: buffers allocated for 1 cards
> RME Hammerfall-DSP: no cards found
> Hammerfall memory allocator: buffers allocated for 1 cards
> RME Hammerfall-DSP: no cards found
> [root@Godzilla root]#

This means that the driver does not find a suitable pci id for a card it
knows about. BUT the memory for the card is actually allocated so the
card is somehow being found right? Which probably means there is one
more place in the hdsp code where the pci id for your card is still

-- Fernando

PlanetCCRMA mailing list