[PlanetCCRMA] Conflict between gimp-print-cups and cups-drivers

Steve Arnold sarnold@arnolds.dhs.org
Thu Dec 5 14:33:00 2002

Fernando Pablo Lopez-Lezcano wrote:
>>I tried to install gimp-print-cups and cups-drivers together on a Red 
>>Hat 7.3 system.  Neither synaptic not apt-get allows me to install both 
>>these packages together. Installing either one removes the other. 
>> Naturally I need them both.  What can I do (, other than try to install 
>>these things without using CCRMA's packages)?
> This seems to be a problem with RedHat itself (as far as I can tell).
> The install fails even if you try to install gimp-print-cups manually by
> downloading the rpm or copying it from the cdrom (I just tried). 
> Some files in that package conflict with files that exist in the
> ghostscript package and you cannot remove ghostscript to resolve the
> conflict without also removing parts of cups (and that is why apt-get or
> synaptic do not let you install both - they are just trying to do the
> best they can with the dependencies explicitly stated in the packages). 
> The only alternative would be to either see if RedHat has updated
> packages or to rebuild a newer version of gimp-print-cups that hopefully
> does not have the conflict with ghostscript.  

It's been several months (and I can't claim to be a CUPS expert) but 
building and installing all the right rpms for CUPS under redhat is 
a pain-in-the-ass.  The default gs package isn't really correct for 
cups; the redhat cups stuff *may* be almost there in RH8.0, but I 
couldn't get it working through a linux gateway (my main subnet runs 
cups just fine).

Here are some pointers for cups: go to the main cups web site and 
read the docs, join the list, etc.  Download the ESP version of the 
ghostscript rpm.  Basically, what you need to do is this:

1) replace the RH ghostscript with ESP ghostscript, and remove all 
the normal redhat print packages.

2) for a cups server, you need the above esp-gs, gs-cups, cups, 
cups-libs, cups-devel, and some kind of driver (either foomatic, 
gimp-print-cups, or whatever).

3) for a cups client, you need all of the above except the drivers.

4) check the printer binaries.  cups binaries install in redhat with 
goofy names (ie, lp.cups, lpq.cups, etc) so you'll have to make 
symlinks or rename them.

It's a bitch to compile initially; there are some circular 
dependencies, especially when you're building from src.rpm like I 
do.  It's actually easier to compile the stuff raw, ie, the old 
./configure, make, make install thing, due to certain rpm defaults 
that aren't correct.  If you're an rpm wizard, and you know the cups 
package dependencies, then you could probably make it correct, but 
I'm not enough of a guru.

I had to do an 'rpm --nodeps ..' once or twice, but I finally got it 
working (but only on one subnet).  If all your Linux cups clients 
are the same version (more or less) then you could do an easier 
binary install, but my machines are all different so I end up 
building all the rpms on each machine (ugh).

I don't know squat about apt-get yet, but I'll bet a smart geek 
could set it up so apt-get could do it (since the tool seems smart 
enough to be able to remove packages, install/build the right ones, 

But I'm not volunteering (I'm way too busy right now) ;-)

The latest info is probably on the following sites:





I didn't say it was trivial, did I?