[PlanetCCRMA] Conflict between gimp-print-cups and cups-drivers

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Thu Dec 5 11:11:02 2002

> I tried to install gimp-print-cups and cups-drivers together on a Red 
> Hat 7.3 system.  Neither synaptic not apt-get allows me to install both 
> these packages together. Installing either one removes the other. 
>  Naturally I need them both.  What can I do (, other than try to install 
> these things without using CCRMA's packages)?

This seems to be a problem with RedHat itself (as far as I can tell).
The install fails even if you try to install gimp-print-cups manually by
downloading the rpm or copying it from the cdrom (I just tried). 

Some files in that package conflict with files that exist in the
ghostscript package and you cannot remove ghostscript to resolve the
conflict without also removing parts of cups (and that is why apt-get or
synaptic do not let you install both - they are just trying to do the
best they can with the dependencies explicitly stated in the packages). 

The only alternative would be to either see if RedHat has updated
packages or to rebuild a newer version of gimp-print-cups that hopefully
does not have the conflict with ghostscript.  

-- Fernando