[PlanetCCRMA] initial observations and broken packages

Steve Arnold sarnold@arnolds.dhs.org
Wed Dec 4 23:44:01 2002


I just started playing with the Planet CCRMA acpi kernel on a fresh 
7.3 install, and I must say it's pretty cool.  The alsa stuff setup 
was about the smoothest I've had so far.  I haven't had the chance 
to play with much of the audio stuff yet, but I have some initial 
observations on things (and a couple of package errors).

I had to configure/compile a custom kernel with an ethernet-usb 
patch for my Sharp Zaurus.  The vanilla 2.4.19 patch applied okay, 
except for one minor hand-edit fix.  I had a little trouble getting 
the new kernel working; at one point last night I had a weird error 
with mkinitrd (I boot off a scsi drive, so I need this).  I tracked 
down the error to a supposedly missing loopback (block) device in 
the kernel.  Is this enabled on the stock kernels provided?  It may 
have been some kind of transient glitch, since I rebuilt the kernel 
again tonight, and mkinitrd worked fine.  Go figure...

I also had another build error with a kernel include file (this was 
a biggie).  I traced it down to a somewhat ugly hack in the 
filesystem partition code here:


where there's an include for an ia-64 header file:

  * Yes, specifying asm-ia64 is ugly, but this lets it build on
  * other platforms too, until efi.h moves to include/linux.
#include <asm-ia64/efi.h>

Well, for me, it didn't build at all, since the typical redhat 
kernel source only includes the i386 headers (including Planet 
CCRMA).  I couldn't seem to make it build, so I grabbed the asm-ia64 
files off my Gentoo box (which uses a *really* plain vanilla 2.4.19 
kernel, and includes headers for all architectures).

Once I got the kernel to build, I tried installing the alsa drivers, 
but they wouldn't install on the new kernel (since redhat tags your 
new kernel with a 'custom' tag on /lib/modules, etc).  So I tried 
building the alsa-driver src.rpms (version 0.9.0-37), however, the 
bzip-tar file inside the rpm is broken (i kept getting an error 
during the unpacking phase).

I ended up using the get-cvs script, which retrieved the current 
source (as of a couple of hours ago).  Then I hacked the spec file 
to build the new cvs source.  I finally have my new kernel with 
sound and the Zaurus driver.  Cool!

Except I don't understand why there are so many alsa src.rpm files? 
(and why is the driver src.rpm broken)  Shouldn't all the rpm 
binaries be built from a single source rpm?  All the alsa source 
(for everything) is in each rpm, which seems like a waste...

Anyway, I only built/installed the latest driver source (and not any 
of the utils, etc) but it seems to be working fine so far (using the 
cmpci driver).

You might want to fix the above glitches, but otherwise it seems 
pretty cool.  I *do* like apt-get; I just wish there were a few more 
packages (like Eterm) nad maybe a few more apt-enabled sources.  I 
even added the tux-family and fresh-rpms to sources.list, but I 
still didn't pick up eterm or enlightenment.  Oh well...