[CM] Getting snd to work with conjure/neovim

Kenneth Flak kennethflak at protonmail.com
Mon Jun 26 11:34:46 PDT 2023

On 26 Jun 2023  10:53, bil at ccrma.Stanford.EDU wrote:
>> 0x00007ffff6e5bc0f in __GI___poll (fds=0x7fffffffd790, nfds=1,
>> timeout=59999)
>>  at ../sysdeps/unix/sysv/linux/poll.c:29
>I think that you're in XtAppMainLoop waiting for an event;
>that is, snd is waiting for you to send input etc.

So it seems... however, when I run this in the terminal (no plugins or nvim magic of any kind, just pure ol' stdio):

cat test.scm | snd

I do get the expected result, as well as the expected return value. However, I can't see any way to do anything more after that. Typing in 

(scale-channel 10) 

and hitting enter has no effect. So yes, something is definitely waiting, but how would I go about sending anything into snd when it's in that state? Oh, I also tried the same thing with snd -noinit, so it shouldn't be a configuration issue.

More information about the Cmdist mailing list