[CM] pipewire Snd and SndLib

Juan Reyes juanig at ccrma.Stanford.EDU
Mon Oct 4 12:04:18 PDT 2021

Hi Bill,

Thanks a lot for your help and suggestions.

Followed your instructions on editing configure.ac but then
after autoconf, make clean and ./configure  --with-alsa --with-jack,
make works fine. However, when I try to make sndplay I'm getting the 


[]# make sndplay
gcc -c -DHAVE_CONFIG_H -I. -g -O2 -fPIC    -D_REENTRANT   sndplay.c
gcc sndplay.c -o sndplay libsndlib.a -lasound -DHAVE_CONFIG_H -I. -g -O2 
-fPIC   -D_REENTRANT   -L/usr/lib64/pipewire-0.3/jack -ljack -ljacknet 
-lsamplerate  -lm -ldl
/usr/bin/ld: libsndlib.a(audio.o): undefined reference to symbol 
/usr/bin/ld: /usr/lib64/libpthread.so.0: error adding symbols: DSO 
missing from command line
collect2: error: ld returned 1 exit status
make: *** [makefile:70: sndplay] Error 1


Checked on libpthread and there is  '/usr/lib64/libpthread-2.33.so'

Tried './configure --with-jack' on Fedora34 and still get same results.

> Run autoconf to remake the configure script.  Then, at least in
> Ubuntu, you need to include the --with-alsa switch to configure.
> make clean
> ./configure --with-alsa --with-jack
> make
> make sndplay

More information about the Cmdist mailing list