[CM] cm: compiled on linux 64, no jack?

cellstorm at brainity.com cellstorm at brainity.com
Thu Jan 29 15:44:50 PST 2015


I tried to compile cm with jack, but its controls do not show up in audio-preferences;
ubuntu 14.04 64; 

  wget http://sourceforge.net/projects/sdif/files/sdif/SDIF-3.11.4/SDIF-3.11.4-src.zip
  unzip SDIF-3.11.4-src.zip
  mv SDIF-3.11.4-src SDIF-3.11.4
  cd SDIF-3.11.4
  ./configure --prefix=`pwd` --enable-shared=no --enable-pthreads=no
  make install

sudo apt-get install
libfreetype6-dev libx11-dev libxinerama-dev libxcursor-dev mesa-common-dev libasound2-dev freeglut3-dev
 libxcomposite-dev libsamplerate0-dev fomus

premake4 --with-sdif=../SDIF-3.11.4/ --with-fomus=/usr --with-oscpack --with-jack 


is there no way to make release? the .make files are set to debug automatically; I changed that to release, and tried to add jack by hand, because it was not added automatically, by
adding -DJUCE_JACK=1 at  DEFINES   
 -ljack  at  LIBS
, but no avail.

what am I doing wrong?

More information about the Cmdist mailing list