[CM] Grace and Fomus on F 14

Heinrich Taube taube at uiuc.edu
Fri Mar 18 08:18:56 PDT 2011

sorry its not working for you. i forwarded your message to david  
psenicka, perhaps he has some idea.
fwiw  im using boost_1_45_0/  . i know that boost_1_39_0/ also worked  
for me. its probably not that hard to uninstall/reinstall boost it  
that is actually the issue.

On Mar 18, 2011, at 10:04 AM, Bill Sack wrote:

> i did try the new beta - everything seems to work great except fomus.
> i've done a bit more googling and discovered that this is a
> longstanding (since 12/10) unresolved problem with fomus and f14 -
> there's a message on the planetccrma list about it that i somehow
> overlooked when it was current.
> the issue has nothing to do with Grace or cm at all - i get the same
> error message trying to run one of the fomus examples in the
> documentation (i.e.: outside of cm).
> i still suspect that it has something to do with the version of boost
> but i don't have the patience to downgrade and recompile right now.
> b
> On Thu, Mar 17, 2011 at 4:36 PM, Heinrich Taube <taube at uiuc.edu>  
> wrote:
>> i just tested fomus 0.1.15 in all the betas I can (osx win32 and  
>> ubuntu)
>> using the complex "prime harmonics" example at the end of the  
>> example file
>> you get by selecting:
>>         Help>Examples>Scheme>Fomus
>> the example ran eveywhere (really fast on osx and ubuntu!),  
>> although on
>> ubuntu i did not get the pdf viewer opening automatically with the  
>> computed
>> score.
>> so im not sure what the issue on your fedora, are you using the  
>> fedora beta1
>> i made today?
>> On Mar 17, 2011, at 1:08 PM, Bill Sack wrote:
>>> i built fomus 1.15 here too and got the same crash when trying the
>>> example. i wonder if this has something to do with the version of
>>> boost that's packaged for f14?
>>> looks like 1.39 on f 12
>>> and 1.44 on f14
>>> maybe i'll try a locally downgraded version of boost and see what  
>>> happens.
>>>> do i need to do something about the lock file or not? maybe i could
>>>> disable
>>>> this on linux , but running two version of grace probably isnt a  
>>>> good
>>>> idea
>>>> as they will both write to the preference file...
>>> would it be hard to have a message echoed to the shell if there's a
>>> permission issue or some other conflict with the lockfile?
>>>> On Mar 17, 2011, at 8:56 AM, Bill Sack wrote:
>>>>> hello again,
>>>>> i'm trying to get Fomus going with Grace on fedora 14. i've  
>>>>> tried the
>>>>> planetccrma packages (cm-grace and fomus), and i've tried a  
>>>>> locally
>>>>> compiled version of fomus-1.12. In both cases the programs show  
>>>>> up in
>>>>> the Grace splash screen, but evaluating any of the examples  
>>>>> crashes
>>>>> Grace with this error echoed:
>>>>> /usr/bin/Grace: symbol lookup error: /usr/lib/fomus/lilyout.so:
>>>>> undefined symbol: _ZN5boost9iostreams22file_descriptor_sourceC1Eib
>>>>> i found an earlier message on this list from D. Phillips with  
>>>>> the same
>>>>> error report, though in his case the problem was apparently  
>>>>> resolved
>>>>> with a reinstall - no such luck in my case.
>>>>> thanking you in advance,
>>>>> b
>>>>> _______________________________________________
>>>>> Cmdist mailing list
>>>>> Cmdist at ccrma.stanford.edu
>>>>> http://ccrma-mail.stanford.edu/mailman/listinfo/cmdist
> _______________________________________________
> Cmdist mailing list
> Cmdist at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/cmdist

More information about the Cmdist mailing list