[CM] cm3 & s7 in xemacs?

Bill Sack bsack23 at gmail.com
Sat Nov 15 08:31:44 PST 2008

hi all,
this is not really a cm problem, but i'm curious: i've tried a few different
ways to get the new cm3/s7 thing running interactively in xemacs, but each
time only succeed in getting a prompt that doesn't evaluate input - i can
type at the prompt, but hitting 'enter' doesn't produce the expected

i've tried the following in my .xemacs/init.el

(setq scheme-program-name "/usr/local/bin/cm3")
;;M-x run-scheme

(setq cm3 "/usr/local/bin/cm3")
(defun cm3s7 () (inferior-lisp cm3))
;;M-: (cm3s7)

(defun cm3s7 ()
    "Runs cm3 in s7 scheme"
    (run-scheme "/usr/local/bin/cm3 -emacs")
    (process-kill-without-query (get-process "scheme")))
;;M-: (cm3s7)

each of these has pretty much the same effect.

but any of these work perfectly in emacs ... any thoughts?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ccrma-mail.stanford.edu/pipermail/cmdist/attachments/20081115/ec1963cf/attachment.html 

More information about the Cmdist mailing list