[CM] Re: CM 2.9.1 + RTS 2.0 released

Burton Samograd kruhft@gmail.com
Wed, 17 May 2006 11:21:45 -0600

andersvi@extern.uio.no writes:

>>>> "R" == Rick Taube <taube@uiuc.edu> writes:
> R> 
>>> away zillions of realtime processes :-) (havent tried with
>>> midishare or osc yet, just portmidi).  This is sbcl-0.9.9*, and
> R> 
> R> you should be able to output to any of them (they are all under
> R> construction...) but only portmidi receving is probably working. in a
> R> nutshell the new receiving api is:
> I tried loading the osc-system, changing "libc.dylib" to
> "libc.so" in "osc/sockets.lisp" to locate the lib on linux, but
> it complains about the library:
>   Error opening shared object "libc.so":
>   /usr/lib/libc.so: invalid ELF header.
>   [Condition of type SIMPLE-ERROR]
> Any clues?

On my system, sometimes things may not be the way they look, or so it
seems.  The actual libc is (and has always been to my knowledge) in
/lib, for some reason they're putting a dynamic linking script in
/usr/lib/libc.so. Maybe code a direct path to your /lib/libc.so.6 to
see if that works...

burton samograd					kruhft .at. gmail
kruhft.blogspot.com	www.myspace.com/kruhft	metashell.blogspot.com