[CM] snd-gtk-alsa "alsa_audio_open: could not set rate to exactly 44100, set to 3200 instead"

Sebastian Tennant sebyte@smolny.plus.com
Thu, 02 Feb 2006 01:00:32 +0000

Fernando Lopez-Lezcano <nando@ccrma.Stanford.EDU> wrote:

>> I'm afraid a lot of what you are saying is over my head, and I can't
>> say I understand the ~/.asoundrc 'language' either.
>> With my existing ~/.asoundrc, (which works with all my other audio
>> apps), when I run snd with the command:
>>   $ SNDLIB_ALSA_DEVICE=plughw:1 snd file.wav
>> it produces the following errors:
>> [...]
> Strange, I'm looking at the current code...
> snd_pcm_hw_params_set_rate_near
>   is not returning a result < 0
>   (otherwise the check right after calling it would return an error)
> so... that would seem to mean that the call was sucessfull (ie: a sample
> rate was selected). Then you get the warning above (about the rate not
> being exactly the same). But there is something very wrong at that
> point, the actual rate reported by alsa is 0! So it is not surprising
> that the next call fails and triggers the parameter dump. That would
> seem to point to some inconsistency in alsa itself, the call should
> either fail with an error return < 0, or it should set the frequency and
> return > 0. 
> What is exactly the hardware in hw:1?

It's an Edirol UA-3FX USB audio I/O device.

> Have you tried to tweak other parameters? In particular I would try:
> set BUFFER_SIZE to < 1024, perhaps 512?
> try with BUFFERS = 2 or 4

OK, I will try this.

> Try _not_ using the .asoundrc to see if that has any influence. 

If I don't use the ~./asoundrc then snd will use card 0; my internal
soundcard and this works absolutely fine, but defeats the object.  I
want to use the USB audio device, which works perfectly well with
every other alsa-aware app, and oss apps too, (when I call them with
the 'aoss' wrapper).