[CM] clm: mixer trouble

Anders Vinjar anders.vinjar@notam02.no
01 Sep 2003 12:38:26 +0200

Heres a possible bug (either in clm or in my brain...)

Im having some trouble mixing multi-channel files with current
clm.  Trying to get channel 3+4 from a 4-channel-file into
channel 1+2 in a stereo-file.  Im using the standard clm-wise

  (frame->file (frame->frame ... (file->frame ...)))

as suggested in the manual, but it leaves just zeros in the
output here.  Tried first using fullmix.ins without luck, also
tried writing a bare-bones version just filling the mixer with
explicit scalers.

Im putting

  '((0.0 0.0) (0.0 0.0) (1.0 0.0) (0.0 1.0))

as the matrix argument into the mixer.

Things seem to work as expected if i just step through the frames
in 'just-lisp-mode.

Heres a call on fullmix:

(with-sound (:channels 2 :srate 44100)
  (fullmix "4-chan.aiff"
           0.0 (sound-duration "4-chan.aiff") 0.0
           '((0.0 0.0)
             (0.0 0.0)
             (1.0 0.0)
             (0.0 1.0))))