[CM] Installing CM under Cygwin on Windows XP

Kenny Tilton ktilton@nyc.rr.com
Tue, 28 Oct 2003 13:38:25 -0500

James Ravan wrote:

>I tried using CM a couple of years ago on a Mac and gave up, mainly because
>Capella wasn't what I needed and it would have been a massive amount of work
>to write a
>graphic interface for the kinds of things I wanted to do. Well, people
>change and the software landscape *certainly* changes, so I'm back trying CM
>again. This time my idea is to use Sibelius (or perhaps Lilypond) as a score
>visualization tool, a MIDI player for playback, and XEmacs as a development
>environment. All of this will run inder Cygwin on Windows because I'd rather
>run Sibelius native on Windows than under a virtual machine on Linux.
>It's perhaps important to tell you that, although I program computers for a
>living as many musicians do, I know next-to-nothing about Lisp.
>My first problem is getting CM installed under Cygwin on XP. First I
>installed CLISP under Cygwin. That seems to have worked; I can get Lisp up
>and typing (exit) gets me out. Then I downloaded CM 2.4.0 to - using
>UNIX/Cygwin syntax - /usr/local/lisp. I untarred it there which created a
>/usr/local/lisp/cm-2.4.0 tree. Then while still in /usr/local/lisp I ran
>clisp and typed:
><start verbatim>
>[1]> (load "/usr/local/lisp/cm-2.4.0/src/cm.lisp")
>*** - EVAL: variable  has no value
>The following restarts are available:
>STORE-VALUE    :R1      You may input a new value for .
>USE-VALUE      :R2      You may input a value to be used instead of .
>*** - UNIX error 13 (EACCES): Permission denied
>The following restarts are available:
>STORE-VALUE    :R1      You may input a new value for .
>USE-VALUE      :R2      You may input a value to be used instead of .
>1. Break [2]>
><end verbatim>
>So I have two problems:
>(1) Since I have no practical experience with Lisp in general or CLISP in
>particular, I don't know how to use the debugger. I have looked online and
>just located a CLISP manual circa 2001, but I have yet to unzip and read it.
>Can anyone point me to the latest CLISP docs? I couldn't find them on the
>CLISP website; there seemed to be only a man page.
>(2) And can someone tell me enough to debug this problem? I don't know why,
>but EVAL seems to have NIL in hand for the symbol when it prints these error
>messages. (Note that on the first error line there are two spaces between
>words "variable" and "has".) According to the walkthrough on CM's website,
>this (load) was just supposed to work. :)
>Thanks for any help.
Apologies ahead of time for what may not be helpful, but I just now 
downloaded the pre-built CLisp win32 binaries (no CYGWIN needed) and was 
able to load CM okay with:

    (load "\\lisp\\cm\\src\\cm.lisp")

If you really need CYGWIN I'll try to find some time to try it under 
that, but that is not my strong area. I have it installed, just need to 
know what you did to set up CLisp.

cheers, kenny


Why Lisp? http://alu.cliki.net/RtL%20Highlight%20Film 

Your Project Here! http://alu.cliki.net/Industry%20Application