[CM] clm under cmucl-18e

Bob Coyne bobcoyne@worldnet.att.net
Sat, 25 Oct 2003 09:30:09 -0400

Bill Schottstaedt wrote:

>  > 1. It calls (load-foreign ...).  Needs to be (ext:load-foreign ...)
> Hmm -- something is odd about this, since it (cmucl 18e) works
> fine for me, but in any case I added it to the import list:

I think I know what it is.  All.lisp doesn't have an in-package at the top.
So it is read into the current package.  I happened to be in my own
package that didn't import from the extensions package -- so I got the error.
If the user is in the cl-user package (the default), this won't happen, since cl-user
imports from extensions.

So, while this won't be a common situation (people having changed
the current package), I think having it explicitly say ext:load-foreign
in all.lisp would be the right solution.  The calls to load-foreign (without
the package prefix) in defins.lisp should should be fine since that file
has an (in-package :clm) at the top.

>    #+cmu (:import-from "EXTENSIONS" "QUIT" "LOAD-FOREIGN")
>  > 2. Various instrument files don't have (in-package :clm) at the top.
> None of them need it, and in fact are probably better off
> without it.

It should probably be documented that you must be in the clm
package to compile these files.  (Maybe it is already...I just tried
compiling them without seeing any instructions)

>  > 3. (with-sound ...) failed when lisp invoked a shell command "sndplay <file>".
>  > I fixed it by setting *clm-player* explicitly.  I guess I could/should change my search
>  > path.  (I didn't see any instructions saying I needed to do that.)
> I included the full pathname at one time, and that caused
> endless trouble; I'll add a note about this to README.clm.

Good, thanks.