[CM] still have problem with xcmnw

Dave Phillips dlphilp@bright.net
Thu, 03 Oct 2002 12:47:19 -0500

rm@fabula.de wrote:

> .... i just installed the latest Debian CMUCL and
> downloaded a new version of cmn just to try out the x-output (never
> worked for me since i usually use Clisp) and it actually worked pretty
> nicely.

I may have discovered what was going wrong. My first try failed because
I hadn't compiled xcmnw, so I built it and tried the test again. I had
not quit CMUCL after the first try, and when I ran it again I received
the error I sent earlier. I quit CMUCL and restarted everything, ran the
test, and there was my perfect xcmnw display. I was very happy, then I
wondered about closing xcmnw. I did a kill-client from the xterm,  ran
the test file again, and got the same error as before. So I quit again,
restarted everything, ran the test but did not kill the display. As long
as xcmnw is up it will update with any call to (output-type :x), which
is really cool. However, when I quit CMUCL I get a stream of 'got 0
bytes reading len?' messages that run until I explicitly kill xcmnw.

So is there any recommended better way of handling xcmnw ?

Btw, I got xemacs, I'm taking the plunge... 

Best regards,

== Dave Phillips

	The Book Of Linux Music & Sound at http://www.nostarch.com/lms.htm
	The Linux Soundapps Site at http://linux-sound.org