[CM] snd with guile 1.5.6

Achim Christian Bornhoeft achim.bornhoeft@web.de
Sun, 30 Jun 2002 17:26:30 +0000

I tried to build snd with guile 1.5.6 and ran into a problem:

After comiling guile 1.5.6 the command

'guile-config --version'  returned  'guile-config - Guile version 1.5.6'


 'guile-config link' returned  '-L/usr/local/lib -lguile -lcrypt -lm'.

Both looked fine for me.
Because I'm running redhat 7.2 and guile 1.3.4 is installed under 
/usr/bin I ran the configure srcipt with

./configure GUILE_CONFIG_path=/usr/local/bin assuming that the script is 
looking for /usr/local/bin/guile-config

the script returned

checking for /usr/lib/snd/bin/guile-config... no
checking for Guile... 1.5.6

where the directory path looks quite strange to me.
Even with removing the old guile files under /usr/bin I got the same 
output and
after compiling snd the program returned

snd: error while loading shared libraries: libguile.so.14: cannot open 
shared object file: No such file or directory

even if I change the enviroment variable 'setenv GUILE_LOAD_PATH 
/usr/local/bin '.

Can somebody help me with this problem?
Thank you in advance.